Clock divider resets with Midi->CV

Anything modular synth related that is not format specific.

Moderators: Kent, luketeaford, Joe.

Post Reply
User avatar
adam s
º¿º
Posts: 118
Joined: Thu Feb 05, 2009 8:19 pm
Location: SF Bay Area

Clock divider resets with Midi->CV

Post by adam s » Fri Dec 18, 2020 12:27 pm

I've been syncing my modular with a Machinedrum via a CV.OCD using 1/16th note ticks into a clock divider (BugBrand CLK2A in my case). I want the divider to reset with the MIDI transport play state, and have configured the CV.OCD to send a trig for that MIDI Message coming from the MD. The signals are produced as expected, but there is a problem: the clock tick immediately after the reset causes the divider to advance, so the divider's pattern is exactly 1/16th note ahead of where I want it to be. I believe the issue is caused by the fact that the clock and reset signals are not happening at *exactly* the same moment, just due to the serial nature of MIDI. When I use analog trigger sources for clock and resets, the divider works as expected (as shown in the picture)

So, I'm wondering, is this a common issue with clock dividers and MIDI, or can some dividers handle a teensy offset between clock and resets signals?

Image

User avatar
cornutt
Fig juggler
Posts: 1412
Joined: Sun Jan 25, 2009 10:06 pm
Location: Rocket City USA

Re: Clock divider resets with Midi->CV

Post by cornutt » Fri Dec 18, 2020 1:50 pm

That looks odd. Does the Machinedrum's clock not stop when it receives an MMC Stop? The clock divider apparently is generating a trigger internally off of the RESET leading edge, so once it resets, it ignores the RESET signal until the next transition. You might want to ask Bugbrand about that. Maybe there's a jumper that changes the behavior so that RESET holds the clock divider until it drops.
Sequence 15 -- sequence15.blogspot.com

User avatar
evs
Super Deluxe Wiggler
Posts: 1432
Joined: Mon Apr 20, 2009 1:49 am
Location: Cologne

Re: Clock divider resets with Midi->CV

Post by evs » Tue Feb 16, 2021 7:47 am

adam s wrote:
Fri Dec 18, 2020 12:27 pm
I've been syncing my modular with a Machinedrum via a CV.OCD using 1/16th note ticks into a clock divider (BugBrand CLK2A in my case). I want the divider to reset with the MIDI transport play state, and have configured the CV.OCD to send a trig for that MIDI Message coming from the MD. The signals are produced as expected, but there is a problem: the clock tick immediately after the reset causes the divider to advance, so the divider's pattern is exactly 1/16th note ahead of where I want it to be. I believe the issue is caused by the fact that the clock and reset signals are not happening at *exactly* the same moment, just due to the serial nature of MIDI. When I use analog trigger sources for clock and resets, the divider works as expected (as shown in the picture)

So, I'm wondering, is this a common issue with clock dividers and MIDI, or can some dividers handle a teensy offset between clock and resets signals?

Image
Habe you solved that issue?
I also have a problem, and I’m using a machinedrum.
But ob my setup the divider is one step behind..
Plus I have the same problem when doing it analog..

viewtopic.php?f=16&t=244741

User avatar
KSS
Super Deluxe Wiggler
Posts: 6088
Joined: Mon Jan 25, 2016 7:28 am

Re: Clock divider resets with Midi->CV

Post by KSS » Thu Feb 18, 2021 1:12 pm

There is another thread active right now Feb18 '21 which discusses a similar problem. The One answer is the Ladik Module recommended in that thread. It basically 're-aligns' the clock and reset signals with some control for adjustment to suit specific problems.

That thread also has "clock divider" in its title.

Edit: https://muffwiggler.com/forum/viewtopic ... 6&t=244741
Ladik U-090 http://ladik.ladik.eu/?page_id=2857
Discussed in this thread
viewtopic.php?f=16&t=166898&hilit=du+seq&start=150

User avatar
adam s
º¿º
Posts: 118
Joined: Thu Feb 05, 2009 8:19 pm
Location: SF Bay Area

Re: Clock divider resets with Midi->CV

Post by adam s » Sun Apr 04, 2021 1:49 am

evs wrote:
Tue Feb 16, 2021 7:47 am
Habe you solved that issue?
I also have a problem, and I’m using a machinedrum.
But ob my setup the divider is one step behind..
Plus I have the same problem when doing it analog..

viewtopic.php?f=16&t=244741
Yes, Jason from sixty four pixels recommended a solution that worked perfectly:
If you have a spare inverter (e.g. an attenuverter at full negative deflection) then you should be able to reset the module at the END of the reset pulse out of the CV.OCD. You have control over the pulse duration, so you can control how long after the clock tick the reset will occur
I have a NOT gate right next to my clock divider, and simply inverting the reset signal solved the issue (didn't need to adjust pulse duration in this case).

Post Reply

Return to “Modular Synth General Discussion”