Sonic Potions LXR Drum Synthesizer

Any music gear discussions that don't fit into one of the other forums.

Moderators: Kent, Joe., luketeaford

Post Reply
roger
Wiggling with Experience
Posts: 285
Joined: Thu Jan 22, 2015 5:30 am
Location: alps

Post by roger »

Redownload the Firmware from the official github, reformat your card and try the update again. Does that help?
lapdog
Learning to Wiggle
Posts: 8
Joined: Mon Feb 12, 2018 7:56 pm
Location: Norway

Post by lapdog »

Redownload the Firmware from the official github, reformat your card and try the update again. Does that help?
Thanks, it didn't make any change unfortunately. I was using the Brendan Clarke firmware, by the way.
gruebleengourd
Super Deluxe Wiggler
Posts: 1056
Joined: Mon Sep 24, 2012 11:49 am

Post by gruebleengourd »

Heya,

Is there an alternative firmware or some other way to get it to send or receive clock (with the trigger i/o board) at 24 ppq (ie DIN sync) so I can sync this with typical drum machines and roland gear?

Poly-rhythms are cool and all but...
User avatar
hautlle
Learning to Wiggle
Posts: 38
Joined: Mon Aug 08, 2016 5:32 pm
Location: KS
Contact:

Post by hautlle »

gruebleengourd wrote:Heya,

Is there an alternative firmware or some other way to get it to send or receive clock (with the trigger i/o board) at 24 ppq (ie DIN sync) so I can sync this with typical drum machines and roland gear?

Poly-rhythms are cool and all but...
You can implement this yourself if you edit the firmware. There was a post about it in regards to the Brendan Clarke firmware but the Sonic Potions forum has been down for a while.....
User avatar
hautlle
Learning to Wiggle
Posts: 38
Joined: Mon Aug 08, 2016 5:32 pm
Location: KS
Contact:

Re: LXR failure

Post by hautlle »

lapdog wrote:Hey,

I'm having my LXR since January 2017 now, and though it was never the most solid gear I had, it was working fine. Yesterday it suddenly died on me.
You'll see the symptom in video 1. Video 2 is showing what happens when I try to reinstall the firmware: "File n".
Seems like a hardware issue. Can someone help me solving this?

Video 1:
[video][/video]

Video 2:
[video][/video]

I would open it up and check the boards. Most likely a cracked joint or something if the firmware reset didn't fix it.
bimbom
Common Wiggler
Posts: 205
Joined: Fri May 01, 2015 5:30 pm
Location: United Kingdom

Post by bimbom »

hi

i bought the angled case a while back but have lost the instructions on how to fit the power switch.
has anyone got it / a picture of theirs fitted ?

i have the kit , 2 x wires with red plugs on the end , a rubber heat shrink thing , screws . the switch is on the case already..
i think it was connected to the board and something needed shorting/connecting on the board too.

cheers.
gear : elektron stuff , nord stuff , roland stuff and little cheap boxes.
www.instagram.com/re5etuk
www.soundcloud.com/re5etuk
User avatar
ludotex
Wiggling with Experience
Posts: 339
Joined: Wed Jan 06, 2016 7:00 am
Location: Space
Contact:

Post by ludotex »

bimbom wrote:hi

i bought the angled case a while back but have lost the instructions on how to fit the power switch.
has anyone got it / a picture of theirs fitted ?

i have the kit , 2 x wires with red plugs on the end , a rubber heat shrink thing , screws . the switch is on the case already..
i think it was connected to the board and something needed shorting/connecting on the board too.

cheers.
Read page 9 and 10 of the docs:
https://www.sonic-potions.com/Documenta ... yGuide.pdf
For a clue :hihi:
---
Latest patchings and experiments: https://www.youtube.com/user/plutotex/videos
gruebleengourd
Super Deluxe Wiggler
Posts: 1056
Joined: Mon Sep 24, 2012 11:49 am

Post by gruebleengourd »

hautlle wrote: You can implement this yourself if you edit the firmware. There was a post about it in regards to the Brendan Clarke firmware but the Sonic Potions forum has been down for a while.....
Yes I realize this, but I'm not looking to reinvent the wheel if someone else has already done this. It seems like such an obvious feature I was hoping someone had tackled it.

I'm deep into other sequencer programming projects at the moment, and am not going to take this on at the moment, maybe someday. In the meanwhile, midi clock it is.
bimbom
Common Wiggler
Posts: 205
Joined: Fri May 01, 2015 5:30 pm
Location: United Kingdom

Post by bimbom »

Thanks
I didn’t think to look at that doc , I was only thinking about the case install guide.
ludotex wrote:
bimbom wrote:hi

i bought the angled case a while back but have lost the instructions on how to fit the power switch.
has anyone got it / a picture of theirs fitted ?

i have the kit , 2 x wires with red plugs on the end , a rubber heat shrink thing , screws . the switch is on the case already..
i think it was connected to the board and something needed shorting/connecting on the board too.

cheers.
Read page 9 and 10 of the docs:
https://www.sonic-potions.com/Documenta ... yGuide.pdf
For a clue :hihi:
gear : elektron stuff , nord stuff , roland stuff and little cheap boxes.
www.instagram.com/re5etuk
www.soundcloud.com/re5etuk
User avatar
hautlle
Learning to Wiggle
Posts: 38
Joined: Mon Aug 08, 2016 5:32 pm
Location: KS
Contact:

Post by hautlle »

After 2+ years my LXR stopped booting up last week :ripbanana:

I came in my studio and it was locked up - not all that uncommon.

I turned it off and back on and now all the LEDs light up but the machine doesn't boot.... It sucks that the SP forum is down.

I guess I'll start checking power points for the different chips, but I don't know jack beyond that when it comes to troubleshooting previously working builds.
mongrol
Common Wiggler
Posts: 200
Joined: Wed Oct 28, 2015 11:44 pm

Post by mongrol »

Could just be the SDcard. Reformat a new one with fresh firmware.
User avatar
hautlle
Learning to Wiggle
Posts: 38
Joined: Mon Aug 08, 2016 5:32 pm
Location: KS
Contact:

Post by hautlle »

mongrol wrote:Could just be the SDcard. Reformat a new one with fresh firmware.
That was the first thing I checked.

It gets to the stage where every LED is lit up and it hangs. The screen never turns on. I've put off troubleshooting and just been messing around with my Octatrack...
ddiamond84
Learning to Wiggle
Posts: 36
Joined: Sat Jun 08, 2019 1:56 pm

Delete

Post by ddiamond84 »

Edit: delete
User avatar
jaybee
Learning to Wiggle
Posts: 3
Joined: Sat Nov 10, 2018 4:02 pm
Location: Hamburg, Germany

Question about LXR output routing

Post by jaybee »

Hallo,
i just finished building my LXR. Everything works fine for now.
But i got a problem with the outputs. If i switch the output in the mix menu i can hear the sound still on L1. I think same with the other output.
I checked the solderingpoints for shorts.

Thanks in advance
Jens
User avatar
BugBrand
Knowledge of Bugs
Posts: 7884
Joined: Tue Jul 15, 2008 11:59 am

Post by BugBrand »

I think the 2nd-ary outputs are maybe normalled (though haven't checked recently) - so if you don't have cables plugged into the extra outputs whatever you pass to those outputs will mix in to the main output.
User avatar
jaybee
Learning to Wiggle
Posts: 3
Joined: Sat Nov 10, 2018 4:02 pm
Location: Hamburg, Germany

Post by jaybee »

BugBrand wrote:I think the 2nd-ary outputs are maybe normalled (though haven't checked recently) - so if you don't have cables plugged into the extra outputs whatever you pass to those outputs will mix in to the main output.
Hi, thanks for the quick answer. Indeed, i connected all outputs to my mixer and now it works as expected.
Now i can assemble the case :nana:
User avatar
mrf
Learning to Wiggle
Posts: 5
Joined: Thu Feb 21, 2019 12:35 pm
Location: russia
Contact:

Post by mrf »

For all, who experienced bad things with LXR, my first recommendation is to check ic mounting sockets. I have worked with some industrial equipment, that had problems with that. All you need is to pull out and reinstall ic's. Don't touch contacts with your hands, and better clean them with alcohol. Also, try to clean boards from old flux (please, don't let liquefied flux pour into buttons or ic sockets). Other potential fault is shorting display to midi socket if you forgot to cut it's pins.
I made video with me trying to do all things "proper" for longevity. It is long, but key things is soldering chips directly into the board, using acid free flux, and clean it anyway. I also made display board more friendly for any fixing or resoldering.
User avatar
flx
Super Deluxe Wiggler
Posts: 1929
Joined: Wed Oct 05, 2011 4:22 pm
Location: Köln, Germany
Contact:

Post by flx »

I would like to sequence the LXR‘s sounds externally. Does anybody know how to change the note numbers of the seven instruments/tracks? The default MIDI notes 36 - 42 but the manual doesn’t say how to change them.
izmond
Common Wiggler
Posts: 78
Joined: Mon Jan 30, 2017 6:18 am
Location: OHIO

Post by izmond »

flx wrote:I would like to sequence the LXR‘s sounds externally. Does anybody know how to change the note numbers of the seven instruments/tracks? The default MIDI notes 36 - 42 but the manual doesn’t say how to change them.
Press Voice, then select the voice you want to change, press mix, then press mix again. On the second page of the mix menu, you'll find ch (midi channel) and nt# (note number). I don't remember exactly how to save these assignments globally but it is done with the save menu.
mongrol
Common Wiggler
Posts: 200
Joined: Wed Oct 28, 2015 11:44 pm

Post by mongrol »

They are saved per kit actually. Not globally I believe. I think they are also 2 octaves out than what they say as well.
MoyaMoya
Wiggling with Experience
Posts: 397
Joined: Sat Jul 06, 2019 10:13 pm

Re: Sonic Potions LXR Drum Synthesizer

Post by MoyaMoya »

I've heard talk of a new firmware update..
Can anyone confirm this?
User avatar
bengarland
Common Wiggler
Posts: 169
Joined: Sun Apr 28, 2019 2:37 am
Location: Osaka

Re: Sonic Potions LXR Drum Synthesizer

Post by bengarland »

It's definitely a rumor but I haven't seen any confirmation from Julian himself. Apparently Andre at TubeOhm is somehow helping with it. The last thing I saw was over a month ago on the LXR Facebook group.
MoyaMoya
Wiggling with Experience
Posts: 397
Joined: Sat Jul 06, 2019 10:13 pm

Re: Sonic Potions LXR Drum Synthesizer

Post by MoyaMoya »

damn..I don't have Facebook so ill have figure out how to peep over there..

I love my LXR its just so damn glitchy
running OWL now..will probably try the BC Firmware next

The glitchness is half the appeal. I can get some wild sounds out of it and groovy too..
only to have it freeze and delete all the patterns.

are there any comparable alternatives I/O wise? Dual stereo and trigger outs?
User avatar
IR
Super Deluxe Wiggler
Posts: 1680
Joined: Mon Jun 10, 2013 7:40 am

Re: Sonic Potions LXR Drum Synthesizer

Post by IR »

MoyaMoya wrote: Tue Aug 11, 2020 10:28 pmare there any comparable alternatives I/O wise? Dual stereo and trigger outs?
Some drum brains probably, but you won't get that type of sequencer or as many sound sculpting options.
User avatar
grm
Common Wiggler
Posts: 131
Joined: Fri Nov 18, 2016 4:49 pm
Location: swamp

Re: Sonic Potions LXR Drum Synthesizer

Post by grm »

can anyone please tell me:
  • if my LXR trigger I/O just don't work ,
  • my triggers are too weak (about 3V from an arduino) or to long, as in not triggery (pulse) enough,
  • or if i just have not figured out how to set the LXR to CLOCK BY TRIGGER IN mode ( i run the V0.37 -BC- OS on it)?
also i have a spare (populated) trigger I/O board to offer (location is finland).
Post Reply

Return to “General Gear”